패킷에 대한 테스트를 할려면 반드시 libpcap 이라는 패키지가 필요하다.  그런데 이것이 버전에 따라 틀리기 때문에 인터넷에서 찾기가 아주 애매하다..

즉시, 테스트를 하여야 하는데 이것 찾는데 시간 다 보냈다.  또한 최신 버전이 아니면 테스트가 되질 않아 하는수 없이 센트OS 5.2 버전을 설치 하였다.

그런데 여기에서도 libpcap 은 설치가 되어 있는데 libpcap-devel 이 설치가 되어 있지 않다..

다행히 최신 버전에 맞는 패키지는 찾을수 있었다..버전이 맞지 않으면 의존성 문제라든지 다른 각종 라이브러리 파일들이 있어야 함으로 아주 짜증이 난다. 

혹시 본인과 같이 고생하는 분들을 위하여 링크 걸어 놓겠다...다행히 제대로 컴파일이 되네...




신고
Posted by 엔시스